home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / x11-wm / e-9999 / e-9999.ebuild < prev    next >
Text File  |  2006-01-09  |  823b  |  36 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/x11-wm/e/e-9999.ebuild,v 1.3 2005/09/25 06:53:57 vapier Exp $
  4.  
  5. ECVS_MODULE="e17/apps/e"
  6. inherit enlightenment
  7.  
  8. DESCRIPTION="the e17 window manager"
  9.  
  10. DEPEND="sys-devel/libtool
  11.     x11-libs/evas
  12.     x11-libs/ecore
  13.     media-libs/edje
  14.     dev-libs/eet
  15.     dev-libs/embryo
  16.     x11-libs/evas"
  17.  
  18. pkg_setup() {
  19.     if ! built_with_use media-libs/edje png ; then
  20.         eerror "Re-emerge edje with USE=png"
  21.         die "Re-emerge edje with USE=png"
  22.     fi
  23.     enlightenment_pkg_setup
  24. }
  25.  
  26. src_install() {
  27.     enlightenment_src_install
  28.     mv "${D}"/usr/bin/enlightenment{,-0.17}
  29. }
  30.  
  31. pkg_postinst() {
  32.     ewarn "This version has been installed as"
  33.     ewarn "'enlightenment-0.17' to avoid conflict"
  34.     ewarn "with enlightenment 0.16 versions."
  35. }
  36.